Symptom
Opening a PR fails. Fix PR creation attempt after the selection of issues to fix fails and displays a 'Something went wrong' message.
Possible Cause
When customers are using a service account to connect to Bitbucket-Server, directly or indirectly, it might be possible that this account does not have an email address associated. Especially when bitbucket-server uses Active Directory for authentication.
Resolution
Add an email address to the service account or use a regular users credential.
If the issue persists
If you receive an error while creating a Fix Pull Request, make sure that you take note of the reference id error message and include that in your ticket with the support team. For example:
Something went wrong.
The issue was logged and will be reviewed shortly. Thanks for your patience.
If this problem persists, please contact support with reference id:
<GUID>
The first thing that we will attempt to do is to recreate the issue in our internal environment, so it would assist us greatly if you would also include the relevant manifest files for the project.
These files could include:
- package.json
- package-lock.json
- yarn.json
- yarn.lock
- packages.config (.NET Framework)
- .proj file (.NET Core)
- project.json (.NET Core)
Gopkg.lock
vendor/vendor.json
- pom.xml
- build.gradle
- build.gradle.kts
- composer.lock (PHP
- requirements.txt (Python)
- Gemfile (Ruby)
- Gemfile.lock (Ruby)
- build.sbt (Scala)